This question was asked in Round 1 of Code Jam 2008 contest.
The problem
You are given two vectors v1=(x1,x2,…,xn) and v2=(y1,y2,…,yn). The scalar product of these vectors is a single number, calculated as x1y1+x2y2+…+xnyn.
Suppose you are allowed to permute the coordinates of each vector as you wish. Choose two permutations such that the scalar product of your two new vectors is the smallest possible, and output that minimum scalar product.
Input
The first line of the input file contains integer number T – the number of test cases. For each test case, the first line contains integer number n. The next two lines contain n integers each, giving the coordinates of v1 and v2 respectively.
Output
For each test case, output a line
Case #X: Y
where X is the test case number, starting from 1, and Y is the minimum scalar product of all permutations of the two given vectors.
Limits
Small dataset
T = 1000
1 ≤ n ≤ 8
-1000 ≤ xi, yi ≤ 1000
Large dataset
T = 10
100 ≤ n ≤ 800
-100000 ≤ xi, yi ≤ 100000
Sample Input:
2
3
1 3 -5
-2 4 1
5
1 2 3 4 5
1 0 1 0 1
Sample Output:
Case #1: -25
Case #2: 6
The simple approach would be to multiply the smaller numbers from one array with the larger numbers of the other array and then sum up their products.
So basically, we sort both the arrays and then multiply the smallest to the largest or we can sort and reverse one array and multiply the same indexes of both arrays. I have used the former one.
import java.io.BufferedReader;
import java.io.DataInputStream;
import java.io.FileInputStream;
import java.io.IOException;
import java.io.InputStreamReader;
import java.math.BigInteger;
import java.util.Arrays;
public class Solution {
public static long[] convertStringToLong(String array[])
{
long longArray[] = new long[array.length];
for (int i = 0; i < array.length; i++) longArray[i] = Long.parseLong(array[i]);
return longArray;
}
public static void main(String[] args) throws IOException {
FileInputStream fis = new FileInputStream("MinimumScalarProductB.in");
DataInputStream in = new DataInputStream(fis);
BufferedReader br = new BufferedReader(new InputStreamReader(in));
int N = Integer.parseInt(br.readLine());
int x = 1;
int totalVectors;
BigInteger min;
long arrX[], arrY[];
while(x <= N)
{
totalVectors = Integer.parseInt(br.readLine());
arrX = convertStringToLong(br.readLine().split(" "));
arrY = convertStringToLong(br.readLine().split(" "));
Arrays.sort(arrX);
Arrays.sort(arrY);
min= new BigInteger("0");
for (int i = 0; i< totalVectors; i++ )
{
min = min.add(new BigInteger(Long.toString(arrX[i] * arrY[(totalVectors-1)-i])));
}
System.out.println("Case #"+x+": "+min);
x++;
}
br.close();
}
}