This program is a solution to studious Student
problem from Facebook Hacker Cup. The problem can be found here.
The Problem
A double-square number is an integer X which can be expressed as the sum of two perfect squares. For example, 10 is a double-square because 10 = 32 + 12. Your task in this problem is, given X, determine the number of ways in which it can be written as the sum of two squares. For example, 10 can only be written as 32 + 12 (we don’t count 12 + 32 as being different). On the other hand, 25 can be written as 52 + 02 or as 42 + 32.
Input: You should first read an integer N, the number of test cases. The next N lines will contain N values of X.
Constraints:
0 ≤ X ≤ 2147483647
1 ≤ N ≤ 100
Output: For each value of X, you should output the number of ways to write X as the sum of two squares.
Example Input
5
10
25
3
0
1
Example Output
Case #1: 1
Case #2: 2
Case #3: 0
Case #4: 1
Case #5: 1
import java.io.BufferedReader;
import java.io.DataInputStream;
import java.io.FileInputStream;
import java.io.FileNotFoundException;
import java.io.IOException;
import java.io.InputStreamReader;
public class DoubleSquares {
DoubleSquares(String inputFile) throws IOException, FileNotFoundException
{
FileInputStream fis = new FileInputStream(inputFile);
DataInputStream in = new DataInputStream(fis);
BufferedReader br = new BufferedReader(new InputStreamReader(in));
String line = null;
System.out.println("Total test cases: "+br.readLine());
while((line = br.readLine()) != null)
{
int num = Integer.valueOf(line);
int count = 0;
for (int i = 0; i <= (int) Math.sqrt(num)+1; i++)
{
for (int j = i;j<=(int) Math.sqrt(num)+1; j++)
{
if ( (i*i) + (j*j) == num) count++;
}
}
System.out.println("Count for "+num+": "+count);
}
br.close();
}
public static void main (String args[]) throws FileNotFoundException, IOException
{
new DoubleSquares("DoubleSquaresInput.txt");
}
}
Output
